Requisiti software possibili

Per la versione QuickStart non vi sono particolari requisiti software, se non una piattaforma per la quale sia stata implementata la J2SE di Sun. Per la QuickStart 2.1.1 è necessaria la J2SE versione 1.4.1.

Per la versione uPortal Only invece oltre alla J2SE sono richiesti un database manager, un application server, il build tool per Java ANT.

Per il database è possibile usare qualunque DBMS per il quale venga fornito un driver JDBC e che abbia il supporto per le operazioni transition safe. La documentazione di uPortal descrive le configurazioni per i seguenti DBMS:

ma probabilmente non sono tutti e gli unici DBMS utilizzabili.
Il DBMS scelto andrà configurato per la piattaforma specifica e poi uPortal vi accederà grazie al driver JDBC. L'unica eccezione è rappresentata da HypersonicSQL il quale, essendo realizzato interamente in Java, è utilizzabile su tutte le piattaforme per le quali è prevista la J2SE.

Come application server è possibile utilizzare Jakarta Tomcat oppure IBM WebSphere. Entrambi i software sono realizzati in Java, quindi multipiattaforma, analogamente a HypersonicSQL.

Infine ANT è anch'esso uno strumento realizzato interamente in Java e valgono le stesse considerazioni fatte per HypersonicSQL e per gli application server.

Avanti >

Vai ad Inizio pagina
Vai al Menu
Indice degli accessKey

Nota: Il contenuto di questo sito fruibile da qualunque browser in qualunque versione. Purtroppo browser corrente non supporta gli standard Web attuali, impedendo la visualizzazione della grafica del sito, per cui se ne raccomanda l'aggiornamento. (Maggiori informazioni)